ESXi 7u2 Update Check Compliance Scan fails – Cannot deploy host upgrade agent

Environment:

vCenter 7.0.2 Build 17958471

2 ESXi hosts 7.0.2 Build 17867351 – HPE ProLiant BL460c Gen10

I recently rebuilt the one ESXi hosts with the HPE ESXi 7.0.2 ISO and had to do an in-place upgrade the other host with the same ISO. They are both in a cluster with HA and I was able to patch both hosts except for a few modules but when I go to scan for updates (check compliance) the rebuilt host throws an error for the task:

“Cannot deploy host upgrade agent. Ensure that vSphere Lifecycle Manager is officially signed. Check the network connectivity and logs of host agent and vpxa for details. “

The upgraded host has no problems and I have been able to vMotion between the two hosts. I’ve tried turning HA off/on, moving host out of cluster, rebooting, removing/uninstalling vmware-fdm vib all without success.

From vpxa.log:

2021-06-11T17:55:07.767Z info vpxa[2102833] [Originator@6876 sub=vpxLro opID=713e2872-9e] [VpxLRO] — BEGIN lro-1262 — agentManager — vim.AgentManager.prepareToUpgrade — 52b95d68-8339-b95a-2a95-69253977945c

2021-06-11T17:55:07.768Z info vpxa[2102833] [Originator@6876 sub=vpxLro opID=713e2872-9e] [VpxLRO] — FINISH lro-1262

2021-06-11T17:55:07.798Z info vpxa[2102820] [Originator@6876 sub=vpxLro opID=27d18e73-ed] [VpxLRO] — BEGIN lro-1263 — agentManager — vim.AgentManager.upgrade — 52b95d68-8339-b95a-2a95-69253977945c

2021-06-11T17:55:08.425Z error vpxa[2102820] [Originator@6876 sub=vpxaVmomi opID=27d18e73-ed] [VpxaClientAdapter::InvokeCommon] Re-throwing method-fault ‘N3Vim5Fault18AgentInstallFailed9ExceptionE(Fault cause: vim.fault.AgentInstallFailed

–> )

–> [context]zKq7AVICAgAAAFeiEAEednB4YQAAfeQ/bGlidm1hY29yZS5zbwAAsm8cAC3ZGgBSWhYBtijrbGlidmltLXR5cGVzLnNvAIFhggUBgSnHBQGBxn4BAQLK7hBsaWJ2bW9taS5zbwACu8MYAmZVGANp0hl2cHhhAAPf1BkCfPoSAmv8EgHC6foB0nvuA/4MJwO6oCsDgcoZA8x2KgNWoyoDyrIqAxlNKgNUGysAHDErAI1sKwBSYTwEO30AbGlicHRocmVhZC5zby4wAAWtqA5saWJjLnNvLjYA[/context]’ received while invoking upgrade on vim.AgentManager:ha-agentmgr

2021-06-11T17:55:08.429Z info vpxa[2102820] [Originator@6876 sub=vpxLro opID=27d18e73-ed] [VpxLRO] — FINISH lro-1263

2021-06-11T17:55:08.429Z info vpxa[2102820] [Originator@6876 sub=Default opID=27d18e73-ed] [VpxLRO] — ERROR lro-1263 — agentManager — vim.AgentManager.upgrade: vim.fault.AgentInstallFailed:

–> Result:

–> (vim.fault.AgentInstallFailed) {

–> faultCause = (vmodl.MethodFault) null,

–> faultMessage = <unset>,

–> reason = “UnknownInstallerError”,

–> statusCode = 126,

–> installerOutput = “Extracting…Done

–> Vua endpoint successfully added.

–> VMware HTTP reverse proxy signalled.

–> nohup: can’t execute ‘/usr/share/vua/vua’: Operation not permitted

–> “

–> msg = “Received SOAP response fault from [<cs p:000000438c607040, TCP:localhost:8307>]: upgrade

–> Cannot install the vCenter Server agent service. Unknown installer error”

–> }

–> Args:

–>

–> Arg executable:

–> “upgrade”

–> Arg signatureFile:

–> “upgrade.sig”

2021-06-11T17:55:08.696Z info vpxa[2102818] [Originator@6876 sub=vpxLro opID=9d46cd4-85] [VpxLRO] — BEGIN lro-1264 — agentManager — vim.AgentManager.prepareToUpgrade — 52b95d68-8339-b95a-2a95-69253977945c

2021-06-11T17:55:08.698Z info vpxa[2102818] [Originator@6876 sub=vpxLro opID=9d46cd4-85] [VpxLRO] — FINISH lro-1264

2021-06-11T17:55:08.708Z info vpxa[2102817] [Originator@6876 sub=vpxLro opID=5934d756-4b] [VpxLRO] — BEGIN lro-1265 — agentManager — vim.AgentManager.upgrade — 52b95d68-8339-b95a-2a95-69253977945c

2021-06-11T17:55:09.228Z info vpxa[2102817] [Originator@6876 sub=vpxLro opID=5934d756-4b] [VpxLRO] — FINISH lro-1265

2021-06-11T17:55:10.884Z info vpxa[2102828] [Originator@6876 sub=vpxLro opID=3f81660d-a2] [VpxLRO] — BEGIN task-432 — patchManager — vim.host.PatchManager.ScanV2 — 52b95d68-8339-b95a-2a95-69253977945c

Not sure if there is something I can try to manually upgrade the agent or find a better explanation of the error in a log.

Thanks for any suggestions.

submitted by /u/RiftRisen
[link] [comments]


Go to Source of this post
Author Of this post: /u/RiftRisen
Title Of post: ESXi 7u2 Update Check Compliance Scan fails – Cannot deploy host upgrade agent
Author Link: {authorlink}